abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 

Willkommen in der Business Community

Die Telekom Community für Geschäftskunden

Sie sind hier:
Aktueller Hinweis
Antworten

Nach Ersatz Speedport durch Digitalisierungsbox Basic schlägt die Registrierung von Siemens/Unify Openstage 15 SIP fehl

1 Sterne Mitglied
1 Sterne Mitglied
Beitrag: 1 von 15

Hallo liebe Telekom Hilft,


nach dem Austausch eines Speedport Routers gegen eine Digitalisierungsbox Basic  (Model ID: 12.39.2.05.00 (ID: VMG8825-D70B-DE02V1F - Mon, 15 Jul 2019 20:49:28 +0200 Serial ID: S182V17001577)) funktioniert das SIP-VoIP-Telefon von Siemens / Unify Openstage 15 nicht mehr mit der im Internet stehenden VoIP Telefonanlage. Die Asterisk VoIP Telefonanlage "sieht" das Telefon, kann es aber nicht ansprechen. Wenn ich den Austausch umkehre und wieder den alten Speedport verwende, funktioniert das VoIP-Telefon sofort wieder von Zauberhand.

 

Das Problem muss also in der Behandlung des UDP Verkehrs im Router bzw. in der Firmware stecken.


Es scheint, dass der Zyxel Router den UDP-SIP-Verkehr auf seltsame Weise stört. Das SIP-Register funktioniert nicht richtig.
Das VoIP-Telefon benötigt keine Portweiterleitung. Normalerweise funktioniert das VoIP-Telefon an jedem Router ohne jegliche Konfiguration im Router für das Telefon.

Ich verwende genau die Standard-Router-Konfiguration, die nach dem Zurücksetzen auf die Werkseinstellungen erstellt wird.
Ich habe erst nach einer Weile versucht, die Konfiguration der Zyxel Firewall im Expertenmodus zu vergrößern:
- UDP / IP Conntrack Timeout: von 60 bis 600
- UDP Port Forward 1024-9999 konfiguriert
(Kein Erfolg)
Ein Flashen dieses Geräts mit der Firmware-Version ZyFW-11.39.6-2019-03-25.img für VMG8825-D70B-DE02V1F war nicht möglich - da das Firmwarefile für dieses Gerät abgelehnt wird.
Ich habe auch versucht, die VoIP-Telefonkonfiguration zu ändern, um das Timeout für die SIP-Registrierung zu erhöhen usw. - ohne Erfolg.

Die Kommunikation zwischen VoIP-Telefon und SIP-PBX funktioniert mit IPv4 und UDP.
Die SIP-TK-Anlage lauscht am Standard-Port 5060. Die Registrierung an der TK-Anlage sieht an der TK-Anlage ganz gut aus - aber das VoIP-Telefon kann die Antwort von der TK-Anlage nicht mehr richtig empfangen.

Die Anleitung für die Digitalisierungsbox erwähnt auch nur, dass VoIP Telefon nur im Telefon selbst konfiguriert sein müssen, um sich mit einen externen VoIP Telefonanlage zu verbinden. (Was ja erledigt ist)

Die Spur des OpenStage 15 deutet auf eine kaputte Antwort hin: (Diese Meldungen erscheinen NICHT bei dem Speedport)

 

SIP Signalling(1437): ./src/sg_engine.cpp:9180 EvPacketReceived(ISipTransportObserver) - RES Code(200) Method(REGISTER)

___TRACE:___ Sun Aug 11 17:48:34 2019.701
SIP Signalling(1436): ./src/sg_engine_reg.cpp:1087 EvFailure(ISipRegistrationSvc)

___TRACE:___ Sun Aug 11 17:48:34 2019.701
SIP Signalling(1436): ./src/sg_engine_reg.cpp:631 ManageRegStatus() - received 200 response (EvFailure)

___TRACE:___ Sun Aug 11 17:48:34 2019.701
SIP Signalling(1436): ./src/sg_engine_reg.cpp:992 ManageRegStatus() - Server response was 200OK, but M5T stack reports EvFailure; is the server RFC3261 compliant?

___TRACE:___ Sun Aug 11 17:48:34 2019.702
SIP Signalling(1436): ./src/sg_engine_reg.cpp:996 ManageRegStatus() - Server is not RFC3261 compliant - trying next register with SetIgnoreContactParamInSuccessResponse( true )

___TRACE:___ Sun Aug 11 17:48:34 2019.702
SIP Signalling(1436): ./src/sg_engine_events.cpp:3930 SetServerStatus: (1), current server status: (1)

___TRACE:___ Sun Aug 11 17:48:34 2019.702
SIP Signalling(1436): ./src/sg_events.cpp:113 STK->SIG TimeoutA() - unLineID(0) unStatusCode(409) bUnRegisterA(0)

___TRACE:___ Sun Aug 11 17:48:34 2019.706
SIP Signalling(473): ./src/sgCDispatcher.cpp:128 sgCDispatcher::sgParseIncomingMessage - event = 105; state = 2

___TRACE:___ Sun Aug 11 17:48:34 2019.706
SIP Signalling(473): ./src/sgCDispatcher.cpp:472 SIG->SIG: sipTimeout




Bei Bedarf kann ich Protokolle, Traces usw. bereitstellen.

Könnten Sie mir bitte einen Hinweis geben, wie man das VoIP mit dem Zyxel Router zum Laufen bringt?

(Zyxel lehnt leider einen Support ab, da das Gerät von der Deutschen Telekom vertrieben wird)

Vielen Dank im Voraus!

14 ANTWORTEN 14
5 Sterne Mitgestalter
5 Sterne Mitgestalter
Beitrag: 2 von 15

Hallo @augustusburger ,

ich selber habe keine Basic.

Hast du den SIP-Verkehr in der Basic schon mal mitgeschnitten (System->Diagnose->Paket-Tracer)?

Kommt die Antwort auf den REGISTER überhaupt am OpenStage an?

 

1 Sterne Mitglied
1 Sterne Mitglied
Beitrag: 3 von 15

Hallo @wari1957 ,

 

den Verkehr habe ich am OpenStage Gerät mitgeschnitten und es kommt die Antwort "Server response was 200OK, but M5T stack reports EvFailure" von der IP-Telefonanlage zurück.

So wie ich es verstehe, ist die Antwort duchgedrungen, aber sie ist verstümmelt.

Es schaut fast so aus, als ob der Zyxel Router einen fehlerhaften SIP ALG (Application Layer Gateway) in seiner Firmware als NAT-Filter integriert hat.

Leider sehe ich keinen Menüpunkt, wo man diesen deaktivieren oder tracen könnte.

 

5 Sterne Mitgestalter
5 Sterne Mitgestalter
Beitrag: 4 von 15

@augustusburger 

Was ist denn an der Nachricht verstümmelt?

Deswegen der Netzwerkmittschnitt, nur der zeigt was Sache ist.

 

5 Sterne Mitgestalter
5 Sterne Mitgestalter
Beitrag: 5 von 15

@augustusburger 

- Leider sehe ich keinen Menüpunkt, wo man diesen deaktivieren oder tracen könnte.

Expertenansicht im Zyxel eingeschaltet?